WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 2 weeks ago

#8908 closed defect (bug) (worksforme)

2.7 Upgrade Broken Permalinks

Reported by: php4ever Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Permalinks Keywords: reporter-feedback
Focuses: Cc:

Description

I set this to MAJOR only because of the issue with URLs changing causing massive 404s

I'll try and be as clear as I can.
In WP, when using the feature under Reading Settings >> Front page displays I notice that all previous sites I had upgraded to 2.7 broke the URL structure that had been in place.

For instance, with "A static page (select below)" Selected and both Home Page and Posts Page set to a specific "PAGE" the permalink URL changes after upgrade.
Front page: Home
Posts page: Blog

Where the URL use to be http://www.domainname.com/blog/post/ or /blog/post.html
After the update, the "single" no longer has /blog/ in the URL

Permalinks are set as follows;

/%postname%/ or simply /%postname%.html

This has happened on all sites I upgraded to WP 2.7

Change History (4)

comment:1 @mrmist6 years ago

  • Keywords reporter-feedback added
  • Priority changed from high to normal
  • Severity changed from major to normal

A few things to clarify here -

  1. From which version was the upgrade?
  2. Were the two settings front page and posts page set to the same page?
  3. How do you see the bug manifesting, because normally the front page would show as /blog/ not /blog/post/ in any event.

For info, I have done a test upgrade from 2.5 -> 2.7 with static page in place, and the same setting was present after the upgrade.

I'd suggest resetting everything to defaults (permalinks and static pages) then back again.

Reporter-feedback needed, demoting until then.

comment:2 @Denis-de-Bernardy6 years ago

I've a few customers who reported this as well. They were upgrading 2.5.x and 2.6.x sites.

comment:3 @Denis-de-Bernardy6 years ago

  • Keywords Static Page Permalinks removed
  • Resolution set to worksforme
  • Status changed from new to closed

I'll reopen with a database dump if I see this happening again

comment:4 @DrewAPicture2 weeks ago

  • Milestone 2.7.2 deleted
Note: See TracTickets for help on using tickets.