WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#8913 closed enhancement (worksforme)

Post published message issue

Reported by: hailin Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

User reported that sometimes they hit publish on a new post. It takes for a long
time, then says "post published." But in the "manage post" menu, it's still
listed as a draft (often without categories we've added), and it doesn't
appear on the page.

Sometimes in the post itself, it says "post published" -- but on the
right side, where the time stamp is, it's listed as a "draft" at the
same time. If we refresh, sometimes the update option will go from
"update post" to "publish," as though we'd never published in the first
place.

I think the issue is inconsistency of message.
We have to account for the fact that write_post can fail, eg: db is busy, timed out, etc. So before displaying "Post published" message in wp-admin/sdiebar.php L98, we should make sure the post is indeed published.

This applies to other code paths as well. Eg, changing status, anything involving db write, it's better to check for the result first before informing users that operation was successful and status has changed.

Change History (4)

#1 @Denis-de-Bernardy
9 years ago

  • Component changed from General to Administration
  • Milestone changed from 2.7.2 to 2.8
  • Priority changed from high to normal
  • Type changed from defect (bug) to enhancement

#2 @FFEMTcJ
9 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.8 to Future Release

#3 @mrmist
7 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Lack of traction suggests that this is not a common issue. It doesn't seem like it's going anywhere without a patch, suggest re-opening with one if it is still a problem.

#4 @nacin
7 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.