WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8946 closed defect (bug) (duplicate)

Redirection after commenting leads to an empty page [not confirmed]

Reported by: DarkPepe Owned by:
Milestone: 2.7.1 Priority: low
Severity: minor Version: 2.7
Component: Comments Keywords: Comments
Focuses: Cc:

Description

Hi,

I found this weird bug when starting a give away contest on my blog were the users need to post 20.000 comments to win a piece of hardware.. anyway... after a few hundred comments (even on crazy rithm like 10 comments per second) we found that every user was beeing redirected to an empty comment page after commenting.

After further investigation, the reason seems to be related with comments wating for aproval.. they kind of "use a comment slot" but they aint show on the comment page, so if you post the comment #21, you will be redirected to the next comment page wich actually doesnt exists. (we are paginating the comments in sections of 20 per page).

I cant confirm if this is a WP bug or my own comment template. The most extensive test was using another of my personal blogs and the problem seems to repeat there too, but again, could be my comment template programing.

If you want to test it, this is the enviroment we have atm:

  • Paginated comments by 20. (displaying them with paginate_comments_links() function instead of reglar next/prev links)
  • At least 1 comment wating for moderation (not SPAM, just wating approval)
  • 19 visible comments on the page + the comment wating for aproval.
  • Then post the 20th comment (actually 21) and you must be redirected to comment page 2 wich doesnt exists.

I hope the explanation is clear enought ... :)

Cheers and Thank you.

Change History (3)

comment:1 DD325 years ago

I've got something similar happening on my host..

Not sure whats causing it, But for example, Paged comments at 100 (Never reaches that anyway), Upon posting ~40th items it redirects me to comment-page-2.. Even though the links on the main page point to page 1.. It could simply be that its not building the comment-tree correctly on the redirect links (cache problem maybe since the comments just been added?), But i'm not sure, I've been meaning to investigate it!

I'll have to take a closer look at some point..

comment:2 ryan5 years ago

#8973 is probably related.

comment:3 DarkPepe5 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Since this is allready beeing discussed (and solved it seems...) I'll close this ticket.

Note: See TracTickets for help on using tickets.