WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8954 closed defect (bug) (invalid)

Setting timezone seems to have no effect

Reported by: jidanni Owned by:
Milestone: Priority: lowest
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Changing the timezone on the /wp-admin/options-general.php doesn't
change how articles are displayed. They still say they were posted at
8PM etc. At least on GNU/Linux.

Yes, I flushed my browser.

Perhaps on the choice, add some words as to exactly what is changed.

Also allow registered users to set their own timezone, like MediaWiki.

Change History (2)

comment:1 DD325 years ago

  • Milestone set to 2.9

Once a post is published, The time is set at that point in time.

Updating the time on posts just because the timezone option has changed has further reaching effects than simply the time displayed, Permalink's can become out of sync(or change), RSS items can be duplicated, etc.

In the same way, If you set a post's time to be 1PM, And then change the timezone to be 5 hours ahead, Would you expect that posts time to be set to 6PM, or to stay as you set it?

comment:2 Otto425 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed
  • Version 2.7 deleted

Yes, not a bug. The post was made at, say, 8PM. Changing the timezone the blog is now in doesn't change when the post was made.

Note: See TracTickets for help on using tickets.