WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 3 years ago

#8976 closed enhancement (fixed)

making "preview changes" more user-friendly

Reported by: jdingman Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: Cc:

Description

Currently, there is a way to "preview changes" on a post, but it's not very use-friendly at all.

Situation: A post is written and already published, so you have the option to "update post," but there is no clear way to "preview changes" that you've made.

You can currently view the changes you've made the post without updating public by letting it auto-save, then clicking "preview," but that's not obvious or clear to the average user (or myself).

What I'm suggesting is adding a link or a button that displays "preview changes" so users can easily see what the changes will look like before the post is updated public.

Change History (16)

comment:1 jdingman5 years ago

  • Keywords needs-patch added

A response from westi,

"<westi> sounds good ... even better if it comes with a patch ;-)"

comment:2 ryan5 years ago

Clicking the Preview button forces an autosave and shows that content in the preview. It already previews changes. Are we suggesting changing the Preview button to say "Preview Changes"?

comment:3 jeremyclarke5 years ago

To clarify what's needed: we don't need any new functionality at all. The problem is just that once a post is published there is just one button to see the post "preview" and its not clear what will happen when you push it.

Currently if you make a change then click preview (without saving) it will show you the post with your changes but will not save it yet. This is what Element is looking for. However it would also be sane to think that that button will link directly to the live version of a post, or that you'd have to save before seeing changes.

The best solution IMHO would be to have two buttons visible after publishing:

View Post
Preview Changes

This would not only make it clear that changes can be previewed before updating the post, but it would also provide a convenient link to the live version of a post for comparison (currently you need to go to your actual blog and find the post to see the live version).

Alternately the label on the 'preview' button could just be changed to "Preview Changes" instead of preview. That would be the smallest possible amount of work (though my feeling is there might as well also be the view post button cause there's empty space and it woudl make the distinction super clear)

comment:5 jeremyclarke5 years ago

  • Cc jeremyclarke added

Thanks for the tip jamescollins, I closed that one 'cause i think this one has better solutions and its the same problem.

comment:6 follow-up: azaozz5 years ago

I'm not sure that "Preview Changes" is better than "Preview". What else can be previewed? Also "Preview Changes" sounds like the changes would be highlighted in some way and we already have that in the revisions.

"View Post" button could be added there although it's available in the "Post saved.." notice too. Also before the post is edited, both buttons would show exactly the same content. Sounds more confusing.

Another option would be to show the "Preview" button only when the post is edited or replace the "View Post" with "Preview", but it won't be available before the first autosave after the content or the title changes.

comment:7 in reply to: ↑ 6 jeremyclarke5 years ago

Replying to azaozz:

I'm not sure that "Preview Changes" is better than "Preview". What else can be previewed?

Nothing else can be previewed really but why not be as accurate as possible? As it is the button just isnt' clear to people. Me, Element and anyone else who doesn't KNOW what it will do would have to guess, and my hunch is that many people would assume that the button would just show the page as it was saved (i.e. that the label is innacurately the same as it was when the post was a draft). Only if you already know or if you test it do you know for sure that it will make a temporary save of the post to show you the preview.

A more pertinent question: What is lost by showing "preview changes" instead?

Also "Preview Changes" sounds like the changes would be highlighted in some way and we already have that in the revisions.

I don't think the highlighting thing is relevant because when they see it isn't highlighted they won't be confused, they'll just see that there's no highlighting. Also revisions only show once you save, and don't help explain what the 'preview' button will do. They are about the past, this button is about the present.

Making the label 'preview changes' has no negative effect and there is space for it. The change also won't confuse any existing users because its just more accurate, no removed information.

"View Post" button could be added there although it's available in the "Post saved.." notice too.

The whole point is to make it clear that people don't have to save published posts before they can see their changes. This needs to be clear before they save so that they dont' save ugly changes if they dont' have to.

Also before the post is edited, both buttons would show exactly the same content. Sounds more confusing.

I think it's pretty clear that the 'show post' button wouldn't be visible until you publish the post. The 'preview changes' button would also obviously need to be 'Preview post' until it is published.

Another option would be to show the "Preview" button only when the post is edited or replace the "View Post" with "Preview", but it won't be available before the first autosave after the content or the title changes.

I like this idea: after publishing there is one button "view post". AFTER you have made some changes the 'preview' or 'preview changes' button appears. THAT SAID: it would be a lot more work that I for one am not willing to do. The earlier proposed changes would be very very fast to accomplish.

So, just to summarize what buttons should be visible:

Draft post: [Preview]

Published post: [View Post] [Preview Changes]

comment:8 filosofo5 years ago

I'll add my vote to changing the wording to "Preview Changes," as I was confused by the current behavior the first time I ran across it, too.

comment:9 markjaquith5 years ago

I'm 100% on board with changing "Preview" to "Preview Changes"

I'm on the fence about "View." I don't think it should go in the
upper-left of the Publish box... that's where the Save Changes button
goes, and I want there to be consistency with that. We could perhaps
put it under the Preview Changes button. Or we could take it out of
the Publish box altogether. It really isn't related to publishing like
preview is... Here's a crazy half-baked idea, just for kicks: put it
next to the permalink, to the right of the Edit button.

Permalink: http://yoursite.com/2009/01/15/title/ [Edit] [View]

Or we can just forget about "View" altogether.

comment:10 azaozz5 years ago

Replying to jeremyclarke:

... THAT SAID: it would be a lot more work that I for one am not willing to do. The earlier proposed changes would be very very fast to accomplish.

Actually it would take just one (short) line of js as the current button works exactly that way. If clicked when there's no changes it shows the post as it was published, if clicked after there have been some changes, it shows the post with the changes.

Replying to markjaquith:

Permalink: http://yoursite.com/2009/01/15/title/ [Edit] [View]

This sounds very good. Will have to show the permalink for sites without pretty permalinks too.

comment:11 azaozz5 years ago

(In [10458]) Show the permalink even when not "pretty" and add "View Post" button if the post is published, see #8976

comment:12 follow-up: Denis-de-Bernardy5 years ago

  • Keywords close added; dev-feedback removed
  • Milestone changed from 2.9 to Future Release

fixed, right?

comment:13 in reply to: ↑ 12 ; follow-up: daveabrahams4 years ago

Replying to Denis-de-Bernardy:

fixed, right?

It's not fixed in any released version of WP. I can always /ask/ to preview my changes to an already-published post, but WP will just show me the published version.

comment:14 johnbillion3 years ago

  • Cc johnbillion@… added

comment:15 in reply to: ↑ 13 solarissmoke3 years ago

  • Keywords needs-patch removed

Replying to daveabrahams:

It's not fixed in any released version of WP. I can always /ask/ to preview my changes to an already-published post, but WP will just show me the published version.

In 3.1RC, if I edit a published post and then click "preview changes", the preview shows the edited content (and not the previously published version). So this looks fixed.

comment:16 markjaquith3 years ago

  • Keywords close removed
  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

daveabrahams — make you're you're not opening the link in a new window. That will not work. You have to actually click it normally. It will preview in a new window. It has to submit a form. Open in new window manually just opens the URL, and doesn't POST the changes.

And the button does say "Preview Changes" now, once a post is published. So this ticket is done.

Note: See TracTickets for help on using tickets.