WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#8979 closed defect (bug) (invalid)

widget disappears after clicking save changes

Reported by: robfelty Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.7
Component: Widgets Keywords: reporter-feedback 2nd-opinion
Focuses: Cc:

Description

Using wordpress 2.7, revision 10186, there is a possible bug in the widget handling. I noticed this for all 4 of the plugins I have written. They worked fine in WP 2.6, but in WP 2.7, when adding a widget, it would disappear from the widget list after saving changes. Eventually I found the problem to be that the id_base cannot be mixed case. At least, changing from mixed case to all lowercase solved the problem for my plugins. But I don't see why that the id_base should have to be all lower case. It seems like WP allows mixed case in most other situations. I have more details about the problem and my experiences on my blog:
http://blog.robfelty.com/2009/01/06/the-right-3-bytes-or-wordpress-plugin-bugs-solved/

I had users of my plugins report this issue in all major browsers. I suspect that the issue is somewhere in the wp_register_sidebar_widget function or the wp_register_widget_control function.

Thanks for all your great work on wordpress!

Rob

Change History (8)

comment:1 @Paleo Pat7 years ago

I can confirm this, not only does it happen on clicking save, but it also happens if you just happen to click on a widget in the center. luckily, if you don't hit have changes and refresh the screen, it will usually still be there.

comment:2 @Paleo Pat7 years ago

Make that "Save Changes" ooops!

comment:3 @Denis-de-Bernardy6 years ago

  • Component changed from Widgets to JavaScript
  • Keywords dev-feedback added
  • Milestone changed from 2.7.2 to 2.8
  • Owner set to azaozz

might be fixed in trunk

comment:5 @ryan6 years ago

  • Component changed from JavaScript to Widgets
  • Owner azaozz deleted

Moving back to Widgets component.

comment:6 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback added; dev-feedback removed

Can you confirm that this is still occurring?

comment:7 @Denis-de-Bernardy6 years ago

  • Keywords 2nd-opinion added

comment:8 @Denis-de-Bernardy6 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

This should be fixed since the save procedure has changed in 2.8.

Please re-open with feedback if it is still occurring.

Note: See TracTickets for help on using tickets.