WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#8989 closed defect (bug) (fixed)

RSS doesn't work in last update

Reported by: bi0xid Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: Feeds Keywords: reporter-feedback
Focuses: Cc:

Description

With last upgrade (2.8-bleeding-edge) RSS doesn't work.

Feed is empty.

wp-rss.php and wp-rss2.php make a redirect 301 to rss url info in the blog that doesn't work.

I have tried using bloginfo instead of get_bloginfo, but doesn't work either.

I have tried to use old wp-rss.php and wp-rss2.php pages, but doesn't work.

I have reinstalled two times, having the same problem.

Is it a common problem, or just mine?

Change History (19)

comment:1 bi0xid5 years ago

It works the same way with new and old pages.

If you try to subscribe, it gives you the URI feed://http//%siteurl%/feed/

comment:2 bi0xid5 years ago

I've been looking in wp-includes/rewrite.php and it seems there's something wrong, but i don't know what. $this->root appears to work properly (it's used in search too and they work).

I'll continue looking.

comment:3 DD325 years ago

  • Version set to 2.8

Is it a live site? posting the URL could help speed it up.

Have you disabled all plugins? Esp. feed related plugins.

I just tested it on an up-to-date install using rewrite permalinks, everything A-OK..

comment:4 bi0xid5 years ago

It's a live site, http://raven.es

I don't know what can be wrong. I have deactivated all plugins and it happens again.
I'm gonna try today back to 2.7 to see what is wrong.

comment:5 bi0xid5 years ago

2.7 with no plugins works properly, RSS URI well formed and RSS well formed.

Trying nightly build.

comment:6 bi0xid5 years ago

It's something in wp-includes directory. I'm gonna upgrade files one-by-one to detect where is the fail.

comment:7 bi0xid5 years ago

functions.php doesn't work for me. If I use 2.7 functions.php, it works correctly. But if I use latest, feed is broken :/

comment:8 DD325 years ago

add define('WP_DEBUG', true); to your config file, see if any PHP errors are output then.

comment:9 bi0xid5 years ago

Thanks. I'll try.

comment:10 DD325 years ago

  • Keywords reporter-feedback added

The RSS feeds are working on the example site provided. Did you fix it? Was it a plugin? (Mark as invalid in the case it was not a bug in WordPress)

comment:11 Bueltge5 years ago

I have add the constants, same problem. Empty page, no error-message.
Only error-messages, when i work in backend - only error from plugins, not on the feed-page. I have deactivate all plugins and all functions of the theme, feed dosn't work.

Now, i have update the last build and the feed dosn't work.
I can not find a problem, may aou have an other idea for tested?

comment:12 bi0xid5 years ago

Tested with auto-upgrade with 2.8-foo version instead of 2.8-bleeding-edge. Same problem. Still malformed. Using 2.7 functions.php works again.

Maybe its $wp_db_version problem? Need to change schema? It's 9872 now.

comment:13 DD325 years ago

Here are all the changes made to wp-includes/functions.php after 2.7 release: http://trac.wordpress.org/changeset?new=trunk%2Fwp-includes%2Ffunctions.php%4010490&old=trunk%2Fwp-includes%2Ffunctions.php%4010150

Nothing jumps out to me..

comment:14 bi0xid5 years ago

Maybe it's a php version problem?

Out of ideas.

comment:15 DD325 years ago

which version of PHP are you running?

comment:16 bi0xid5 years ago

Apache/1.3.39 (Unix) mod_python/2.7.11 Python/2.4.4 mod_perl/1.29 PHP/5.2.6 MySQL/4.1.22

No problems in the rest of installations <=2.7

comment:17 Bueltge5 years ago

I have the problem, with 2.7 functions.php works.
PHP/5.2.6, Server API/Apache 2.0 Handler, mySQL/5.0.67

comment:19 westi5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [10504]) Respect the translation argument of mysql2date again. Fixes #9035 and #8989.

Note: See TracTickets for help on using tickets.