WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 12 days ago

#9016 closed feature request (duplicate)

Possibility to disable wp-cron

Reported by: erunafailaro Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: wp-cron
Focuses: Cc:

Description

Sometime when I edit an older page or article and save the changes, spawn_cron() from /wp-includes/cron.php is invoked more than 200 times a second for a few minutes and consequently also calls /wp-cron.php > 200 times.

Everytime when this happens, my server goes down to its knees and my provider will take my host offline.

As my provider offers operating-system-cron-jobs, I would like to replace wp-cron with an OS-cron-job that will invoke /wp-cron.php once a minute.

Could you please add an option to the wp-settings that will disable wp-cron so that the file /wp-cron.php could be invoked by e.g. an OS-cronjob?

Change History (2)

comment:1 @sivel6 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #9005.

This is already being worked on for 2.8.

In the mean time you can drop the following into wp-config.php

define('DOING_CRON', true);

Alternatively you can drop the following into your themes functions.php

remove_action('init', 'wp_cron');

Then you will either need to get the URL with the query string from your access log or determine what the result of wp_hash('187425') is for your install.

The resulting url should look something like http://example.org/wp-cron.php?check=6f4e34aa4940414f4640443424747cc5

Then you need to schedule cron to curl or wget this url. Currently the call in WordPress uses POST instead of GET.

comment:2 @DrewAPicture12 days ago

  • Milestone 2.7.1 deleted
Note: See TracTickets for help on using tickets.