Make WordPress Core

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#9034 closed defect (bug) (invalid)

clean post cache after publish_future_post event is fired and post is changed

Reported by: hailin's profile hailin Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: General Keywords: has-patch
Focuses: Cc:

Description

After lengthy debugging, it turns out that in many cases where "Missed Schedule" is diplayed, the root cause is that we didn't clean the post cache after the post status is changed from future to publish.

When any portion of post is changed, we should invalidate the post cache.

Attachments (1)

9034_post_cache.diff (763 bytes) - added by hailin 13 years ago.
updated patch

Download all attachments as: .zip

Change History (6)

#1 @lloydbudd
13 years ago

  • Keywords has-patch added

#2 @lloydbudd
13 years ago

  • Version set to 2.7

@hailin
13 years ago

updated patch

#3 @ryan
13 years ago

That triggers the save_post action which calls _save_post_hook() which does the cache flush.

#4 @hailin
13 years ago

  • Resolution set to invalid
  • Status changed from new to closed

#5 @lloydbudd
13 years ago

  • Milestone 2.8 deleted
Note: See TracTickets for help on using tickets.