WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 2 years ago

#9087 closed enhancement (wontfix)

"Edit Posts" heading in /wp-admin/edit.php should state filters (i.e. Edit Posts for category "General")

Reported by: jeremyclarke Owned by: jeremyclarke
Milestone: Priority: normal
Severity: normal Version:
Component: UI Keywords: needs-patch
Focuses: Cc:

Description

While you could argue that the selected value in the relevant pulldown menu is enough information for people I don't see any good reasons why the title of the page shouldn't also mention any filters (Date, category, tag, status or author) that are currently being applied to the content.

There is lots of space there in almost all cases and it would help people understand what they are looking at, especially if they are brought there from somewhere else in the admin via. a link.

I have a specific problem because even though there is an ?author=$ID filter available to edit.php there is no pulldown for author names (there's another ticket about that somewhere), so I've created links in the user profile screen to the edit.php screen for specific users (and to user+status combinations, which our editors need) using plugin code. The problem is that on arrival there's no information visible anywhere as to what the screen is. If you don't look carefully at the user names and statuses you might think you were just looking at the normal edit screen, whereas a heading of "Edit Pending Posts by Jane" would make it totally clear.

I can't think of a reason not to do this. It would solve my situation and make all the other more general situations clearer.

Change History (6)

comment:1 jeremyclarke5 years ago

  • Cc janeforshort added

comment:2 janeforshort5 years ago

We had it this way in an earlier pre-release version, I think. I can't remember what the reason was for taking it out... it may have been a space issue, I think. We can look at this again, as we're looking at search results labeling as well.

comment:3 Viper007Bond5 years ago

  • Type changed from defect (bug) to enhancement

comment:4 janeforshort5 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to time constraints, will reconsider for upcoming release cycle.

comment:5 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added

comment:6 ryan2 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.