WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#9091 closed defect (bug) (fixed)

Creating a bulleted list in a new post causes text area to lose focus

Reported by: duckpuppy Owned by: azaozz
Milestone: 2.9 Priority: lowest
Severity: trivial Version: 2.7
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Pressing the "Unordered List" button or using the Alt-Shift-U keyboard shortcut to create an unordered list causes the text box to lose focus, requiring the user to click in the text box to continue typing. This is especially aggravating when using keyboard shortcuts during post entry. Using the "Unordered List" button or Alt-Shift-U to CLOSE a list leaves the cursor at the appropriate position in the text area. The focus loss only occurs when STARTING a list.

Change History (13)

comment:1 follow-up: @azaozz6 years ago

  • Keywords reporter-feedback added

In which browser(s) is this happening? Cannot reproduce in any of the newer browsers.

comment:2 in reply to: ↑ 1 @duckpuppy6 years ago

Replying to azaozz:

In which browser(s) is this happening? Cannot reproduce in any of the newer browsers.

Google Chrome 1.0.154.53 (Current stable build as of today)
I can also confirm that the behavior still exists in Google Chrome's current development build as well.

comment:3 @janeforshort6 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to feature freeze. Reconsider with next release.

comment:4 @Denis-de-Bernardy6 years ago

this should probably be sent upstream to moxiecode.

comment:5 @Denis-de-Bernardy6 years ago

  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

still current?

comment:6 @Denis-de-Bernardy6 years ago

  • Milestone changed from Future Release to 2.9

comment:7 @Denis-de-Bernardy6 years ago

http://tinymce.moxiecode.com/examples/full.php doesn't have the shortcut, so nm on sending it upstream.

comment:8 @tvallier6 years ago

I can confirm it on both the button click and the shortcut in Chrome developer build version 2.0.181.1

comment:9 @eddieringle6 years ago

  • Cc eddie@… added

Both the button and shortcut work for me on Chromium Linux 4.0.223.3 (Ubuntu build 29376).

comment:10 follow-up: @azaozz6 years ago

  • Keywords reporter-feedback removed
  • Resolution set to fixed
  • Status changed from new to closed

Yes, this has been fixed in the latest TinyMCE (curently in trunk).

comment:11 in reply to: ↑ 10 @duckpuppy5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to azaozz:

Yes, this has been fixed in the latest TinyMCE (curently in trunk).

This is still a problem in Wordpress 3.0.1 and Chrome 6.0.472.14 on Windows. I've not seen this problem go away since I first reported it.

comment:12 @duckpuppy5 years ago

  • Cc paikens@… added

comment:13 @nacin5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Please don't re-open old tickets that have been closed on a milestone. In this case, there are a few tickets referring to incompatibilities with the latest Chrome and the latest WordPress, which will be handled in 3.1 when we upgrade TinyMCE.

Note: See TracTickets for help on using tickets.