WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#9122 closed defect (bug) (fixed)

Localize string for recent comments mismatched.

Reported by: lilyfan Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: I18N Keywords: dashboard
Focuses: Cc:

Description

The localize string '%1$s on %2$s' (for recent comments) is not suitable for dashboard. This must be changed.

'%1$s on %2$s' is shown at line 4083 at ja.po,
and used at two places.

#: wp-admin/includes/dashboard.php:520

#: wp-includes/widgets.php:1401

This string is translated as "(投稿タイトル) に (コメント種別) より" (meanings: "for (title) from (comment type)") at the dashboard. This translation is no good, because "より" (== from) is redundant.

The root cause is that mismatch of purpose of "%1$s":
At dashboard.php: it represents comment type.
At widgets.php: it represents commenter author's name.

This localize string must be separated each other.

I suggest that '%1$s on %2$s' is only for dashboard.php, and for widgets.php, the existing string 'From %1$s on %2$s%3$' is suitable.

Change History (1)

comment:1 nbachiyski5 years ago

  • Milestone 2.7.2 deleted
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [10680].

Note: See TracTickets for help on using tickets.