WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9123 closed defect (bug) (fixed)

The word 'Pending' for posts must be separated

Reported by: lilyfan Owned by: nbachiyski
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords: pending
Focuses: Cc:

Description

In edit.php, posts in pending preview are shown as "Pending".

In php code, __() function is used for this localizing string.

$post_states[] = __('Pending');

(line 3289 of wp-admin/includes/template.php)

But, in po file, the string for "Pending" is plural forms.

  #: wp-admin/includes/dashboard.php:244
  #: wp-admin/includes/template.php:3289
  msgid "Pending"
  msgid_plural "Pending"
  msgstr[0] "承認待ち"

(line 3943 of wp-content/languages/ja.po)

Therefore, translation for this string is failed!!

The word 'Pending' is also used for comments. Line 3943 of ja.po is for pending comments.

The root cause is:
(1) mismatch of using 'pending' between posts and comments.
(2) mismatch of sigle/plural forms at php code and at po file.

I suggest to make "Pending|posts" string for this.

$post_states[] = _c('Pending|posts');

Change History (1)

comment:1 nbachiyski5 years ago

  • Milestone 2.7.2 deleted
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in [10680].

Note: See TracTickets for help on using tickets.