Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#9131 closed enhancement (duplicate)

add <link> rel="prev", rel="next", etc.

Reported by: jidanni Owned by:
Milestone: Priority: lowest
Severity: trivial Version: 2.7
Component: Template Keywords:
Focuses: Cc:


One thing wordpress and its default themes perhaps may have
ignored, and you might want to put on your long term TODO list,
is the functionality of the full set of <link> parameters.
E.g., the

<link rev="made" href="mailto:joerg@debian.org">
<link rel="index" href="maillist.html">
<link rel="top" href="threads.html">
<link rel="up" href="msg00267.html">
<link rel="prev" href="msg00267.html">
<link rel="next" href="msg00284.html">

in say the headers of

Let's take the rel="prev" link for instance. This is used by e.g., the
emacs-w3m browser for

<backspace> runs the command w3m-scroll-down-or-previous-url
  which is an interactive compiled Lisp function in `w3m.el'.
It is bound to DEL, S-SPC, <delete>, <backspace>.
(w3m-scroll-down-or-previous-url ARG)

Scroll the current window down ARG lines, or go to the previous page.

Note that this is not the same as a browser's BACK function, (which is
in emacs-w3m:)

B runs the command w3m-view-previous-page
  which is an interactive compiled Lisp function in `w3m.el'.
It is bound to B, <left>, <tool-bar> <w3m-view-previous-page>, <menu-bar> <w3m> <Back to Previous Page>.
(w3m-view-previous-page &optional count)
Move back count pages in the history.
If count is a positive integer, move backward count times in the
history.  If count is a negative integer, moving forward is performed.
count is treated as 1 by default if it is omitted.

Anyway in addition to the current posts_nav_link(), you would want to make some
these <link>s for <head>.

Change History (1)

#1 @westi
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8703

Note: See TracTickets for help on using tickets.