WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 9 years ago

Last modified 3 years ago

#9136 closed defect (bug) (invalid)

Private Post Cannot Be Unpublished

Reported by: miqrogroove Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

Steps to reproduce:

Create a new draft. Change the visibility to Private. Save/Preview, whatever. Click Publish. View/Comment whatever. Now go back and try to edit.

If I use Quick Edit: I can change the status from Published to Unpublished and click Update Post, but this only causes the Quick Edit dialog to disappear. No changes are saved.

If I use full Edit: There are no options to Unpublish. I can only Delete or change the Published on datetime.

Attachments (1)

Private Post Edit - Ticket #9136.gif (5.5 KB) - added by miqrogroove 9 years ago.
My screen shot of the Private Post Edit options.

Download all attachments as: .zip

Change History (10)

@miqrogroove
9 years ago

My screen shot of the Private Post Edit options.

#1 @miqrogroove
9 years ago

Another author at my site says:

hey i changed it. u have to change it to public, then change it to draft then change it back to private lol so lonnng process

#2 @FFEMTcJ
9 years ago

  • Keywords reporter-feedback added

From the WP Glossary:

Post Status

The status of a post, as set in the Administration Panel, Write Post SubPanel is either: Published (viewable by everyone), Draft (incomplete post viewable by anyone with proper user level), or Private (viewable only to you)

So does it really matter if it is Published or Unpublished?

#3 @miqrogroove
9 years ago

  • Keywords reporter-feedback removed

From the WP Glossary

It doesn't matter how you define it. Quick Edit is still broken. And as my friend said, there is no option to set a Private post to Draft status.

Please try to understand the issue before suggesting it doesn't matter.

#4 @FFEMTcJ
9 years ago

  • Resolution set to invalid
  • Status changed from new to closed

If you click private on a new post it publishes it automatically as private. That is the intent of the design. On the quick edit page, if you uncheck private, you can then change the status. Once again the intent. Closing as invalid.

#5 @DD32
9 years ago

  • Component changed from General to Administration

Full edit: Seems correct to me, Change the Visibility to a public post, which then allows you to set it as a draft, You cant make it a draft and retain the private post status.

quick edit: Removing the Private checkbox, and setting it to Unpublished seems to work as expected to set it as a draft.

"Private" vs. "Public" is the main differentiator, With a Private post automatically being a "Published" post, If you remove the Private selection, That then turns it from a 'Private Published', to a 'Public Published' post, If you want to make it a draft, You need to remove it from the private arena, And set its status to a Unpublished post..

The use of "Unpublished" vs "Draft" is a bit confusing though..

(looks like FFEMTcJ has said this, but i've typed it.. so..)

#6 @miqrogroove
9 years ago

ok thanks for nothing guys. I'm so glad I took the time to report this bug.

#7 @FFEMTcJ
9 years ago

It's not a bug. See #5608 also. It could possibly be considered as a feature request to have the ability to have a private unpublished post, but as of now, it isn't designed to work this way on purpose.

#8 @voyagerfan5761
8 years ago

  • Cc WordPress@… added

#9 @DrewAPicture
3 years ago

  • Milestone 2.7.2 deleted
Note: See TracTickets for help on using tickets.