WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9219 closed enhancement (worksforme)

allow saying no to sample posts, comments, and links upon install

Reported by: jidanni Owned by:
Milestone: Priority: lowest
Severity: trivial Version: 2.7.1
Component: Administration Keywords:
Focuses: Cc:

Description

Often one finds oneself installing and reinstalling wordpress several
times during testing.

One must manually remove the sample posts, comments, links, etc. each
time, via clicking, to achieve a clean install, "ready to hand over to
the customer."

It would be nice if there was some define()s one could put in say
wp-config.php, to say that we don't want any of these.

But that line would only be relevant to the install, and would be a
waste to leave lying in wp-config.php.

So maybe it should be able to be put in a different file...

(Yes, there might be some underhanded SQL one could run instead to clean the mess up, but such home remedies ... are usually the cause why we end up reinstalling things!)

Change History (5)

comment:1 Denis-de-Bernardy5 years ago

Wouldn't it be sweeter to dump those defaults altogether?

comment:2 westi5 years ago

  • Milestone Unassigned deleted
  • Resolution set to worksforme
  • Status changed from new to closed

This is already possible.

Add a file called install.php to wp-content

define a function called 'wp_install_defaults' which does nothing (well you might need the default category)

This will override the defaults at install time.

comment:4 jidanni5 years ago

Well, I'd document an easy way to opt-out in wp-config-sample.php. P.S.:

http://lorelle.wordpress.com/2006/01/15/dyi-search-engine-optimization/

In fact, with WordPress, before you even publish your first post, the first test post called Hello World on WordPress issued pings the moment it was installed.

not sure if this is still for real.

comment:5 jidanni5 years ago

  • Cc jidanni@… added
Note: See TracTickets for help on using tickets.