WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9222 closed defect (bug) (duplicate)

bug with wp_title() on homepage

Reported by: thomask Owned by:
Milestone: Priority: high
Severity: trivial Version: 2.7.1
Component: General Keywords:
Focuses: Cc:

Description

i have posted a bugreport that wp_title is not working on homepage for both static page and news page. I do not see it here, but i have probably found the problem

in general-template.php, in wp_title function, row 435, there is

if ( is_single()
( is_page() && !is_front_page() ) ) {

so the front page is explicitely excluded. And the problem is, that there is no definition for front page. So you should add definition for front page, or delete "&& !is_front_page()" part (but i do not know if it would work for front_page which is not Page)

Change History (1)

comment:1 @FFEMTcJ6 years ago

  • Keywords wp_title removed
  • Milestone Unassigned deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closed as dup of #9221

Note: See TracTickets for help on using tickets.