Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#9229 closed defect (bug) (fixed)

wp_list_authors causes duplicates and bad html syntax

Reported by: hailin Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.7.1
Component: General Keywords:
Focuses: Cc:


When there are many authors, and some authors have 0 posts,
the output of wp_list_authors contains duplicates. and with default
'hide_empty' => true, it outputs , , , for those authors.

The root cause is that $link is not initialized in the loop, and
another hole in the logic.

Attachments (1)

9229_list_autor.diff (751 bytes) - added by hailin 7 years ago.

Download all attachments as: .zip

Change History (3)

@hailin7 years ago


comment:1 @lloydbudd7 years ago

  • Cc has-patch added
  • Milestone changed from Unassigned to 2.8
  • Version set to 2.7.1

comment:2 @ryan7 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [10644]) wp_list_authors fixes. Props hailin. fixes #9229

Note: See TracTickets for help on using tickets.