Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#9236 closed enhancement (duplicate)

Improve categories/tags in ATOM feeds

Reported by: andy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Feeds Keywords:
Focuses: Cc:


Currently we do not differentiate between categories and tags, and we combine them if a post has the same term in both taxonomies.

<category scheme="http://myblog.com" term="Cats" />
<category scheme="http://myblog.com" term="Dogs" />

Attached patch adds support for permastruct-based category schema, uses term->slug for term and term->name for label.

This way, you can construct the category/tag URL from the scheme+term. Here is sample output:

<category scheme="http://myblog.com/category/" term="cats" label="Cats" />
<category scheme="http://myblog.com/category/" term="dogs" label="Dogs" />
<category scheme="http://myblog.com/tag/" term="dogs" label="Dogs" />

Support for custom taxonomies remains a problem for plugins to solve.

Attachments (1)

atom-categories.diff (2.9 KB) - added by andy 7 years ago.

Download all attachments as: .zip

Change History (7)

7 years ago

7 years ago

  • Milestone changed from Unassigned to 2.8

7 years ago

  • Keywords has-patch needs-testing added

#3 @peaceablewhale
7 years ago

#8828 attempts to fix the same issue.

#4 @Denis-de-Bernardy
7 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone changed from 2.8 to Future Release

broken patch

#5 @Denis-de-Bernardy
6 years ago

  • Keywords needs-testing removed

#6 @peaceablewhale
6 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as the duplicate of #8828.

Note: See TracTickets for help on using tickets.