WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

#9255 closed defect (bug) (duplicate)

Media manager selects wrong image size

Reported by: gmpfree Owned by:
Milestone: 2.9 Priority: low
Severity: minor Version: 2.7
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

symptom:

full-size image is selected in place of medium size by default.

steps to reproduce:

  1. upload an image of size between "medium" & "large" value.
  1. check wp-settings-1 cookie is NOT set, as /wp-includes/js/swfupload/handlers.js attempts to "cache" last values for alignment & size, hiding the problem from user.
  1. now in item-list the full-size image should be selected instead of the medium.

viewing the source reveal both "medium" and "large" are checked, firefox 3 opts to render latter radio-box checked.

I believe the problem originates from

/wp-admin/includes/media.php

where function image_size_input_fields set $checked first to "medium" then to "full", in above case.

Change History (4)

comment:1 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added
  • Milestone changed from 2.7.2 to 2.8
  • Version set to 2.7

comment:2 janeforshort5 years ago

  • Milestone changed from 2.8 to Future Release

Pushing due to schedule. Can evaluate in next release cycle.

comment:3 Denis-de-Bernardy5 years ago

  • Milestone changed from Future Release to 2.9

comment:4 miqrogroove4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Valid bug, closing as there was a patch already made for duplicate #11021.

Note: See TracTickets for help on using tickets.