WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#9261 closed defect (bug) (fixed)

Can't approve pending comments using quick edit

Reported by: sillybean Owned by: ryan
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.7.1
Component: Comments Keywords: reporter-feedback
Focuses: Cc:

Description

A number of us (http://wordpress.org/support/topic/230210?replies=9) are having issues trying to approve comments from the pending queue using the quick edit links. The comment will either turn white as though it has been approved, or it will reappear after a moment with the message "An unidentified error has occurred."

The comments can be approved by editing each one individually, just not from the list.

Change History (12)

#1 @sillybean
10 years ago

  • Cc sillybean added

#2 @ryan
10 years ago

(In [10681]) Add some error feedback to ajax comment moderation. see #9261

#3 @ryan
10 years ago

"An unidentified error has occurred." suggest problems updating the DB or finding the comment ID. [10681] adds more informative error messages to trunk. Can you test against trunk? If not, I can try porting to 2.7.

#4 @ryan
10 years ago

  • Milestone changed from Unassigned to 2.8
  • Owner set to ryan

#5 @Viper007Bond
10 years ago

  • Keywords reporter-feedback added; comments quickedit removed

#6 @sillybean
10 years ago

I would test against trunk, but the problem is intermittent and elusive. I was having some other issues with character encoding, and converting the databases from western latin to UTF encoding seemed to solve the problem on all my affected blogs... but today it popped up again. I can't find anything unusual about the comment that got stuck except that it contained a hash mark (part of a Twitter discussion).

If porting your patch to 2.7 would not be too much trouble, I'd be happy to test it for you. The one remaining site that's affected is a large production site that I'm extremely reluctant to upgrade.

#7 @Denis-de-Bernardy
10 years ago

I had the same issue at one point, but I then discovered it was a bug in hashcash. disabling hashcash in the admin area fixed it.

#8 @matthewc
10 years ago

I just added some more info to the forum thread linked above. In my case, this issue seems to be caused by the debian package for wordpress using a separate copy of phpmailer which is no longer php4 compatible. When the comment approval process attempts to load phpmailer to notify you a new comment has been posted, it hits a parse error and stops. I haven't dug into why the edit comment method still works, but I presume it doesn't try to email you in that case.

Matthew

#9 @janeforshort
10 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to feature freeze. Reconsider with next release.

#11 @Denis-de-Bernardy
10 years ago

  • Milestone changed from Future Release to 2.8.1

suggesting we close this as fixed in 2.8

#12 @ryan
10 years ago

  • Milestone changed from 2.8.1 to 2.8
  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.