WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#9331 closed defect (bug) (worksforme)

JavaScript on permalinks admin page has gone insane

Reported by: docwhat Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: Permalinks Keywords: reporter-feedback
Focuses: Cc:

Description

I just visited the Permalinks on my blog, verified it was still set to "Month and Name" and clicked "Save Changes" to refresh the .htaccess.

What happened is it said that it saved my preferences, but it was set to default. My .htaccess was emptied (only the comments marking the beginning and end) and all permalinks were turned off.

I was rather distressed, needless to say...

I discovered also that I could not type anything in the custom permalink; it would be magically erased as soon as focus went away.

So I disabled JavaScript in my browser and was able to set my preference and save it.

Ciao!

Change History (2)

comment:1 @mrmist6 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Unassigned to 2.9
  • Severity changed from major to normal

Can't reproduce. Which browser / OS was this seen in?

comment:2 @Denis-de-Bernardy6 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

i've seen my own htaccess get deleted too, but it was due to a caching plugin.

please re-open with feedback.

Note: See TracTickets for help on using tickets.