WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#934 closed defect (bug) (fixed)

Strange pages bugs

Reported by: noderat Owned by: michel v
Milestone: Priority: normal
Severity: major Version: 1.5
Component: Administration Keywords:
Focuses: Cc:

Description

Noticed a few bugs with pages.

When viewing a page the Pages list in the sidebar either is blank or displays:

Warning: Invalid argument supplied for foreach() in /var/www/chris.coggburn.us/wp-includes/template-functions-post.php on line 368

Example is at http://chris.coggburn.us

Change History (14)

comment:1 @noderat10 years ago

  • Patch set to No

comment:2 @tuxp310 years ago

this possibly might be a copy of bug 912

http://mosquito.wordpress.org/view.php?id=912

fix there, try it out.

Tuxp3

comment:3 @noderat10 years ago

I tried that patch, and the issue is unrelated.

comment:4 @tuxp310 years ago

okay thanks, i will look more into it

comment:5 @noderat10 years ago

The bug occurs because of SVN Revision 2354 on the file wp-includes/template-functions-post.php.

When up moved to revision 2353 the bug stopped completely.

comment:6 @ryan10 years ago

Is it still a problem with rev 2360?

http://trac.wordpress.org/changeset/2360

comment:7 @noderat10 years ago

The bug is still a problem in the latest SVN code as well as 2360

comment:8 @anonymousbugger10 years ago

Just noticed this, the default template does not have this problem but has the same wp_list_pages() tag as my template. The classic template, however, does suffer from this problem. Weird.

comment:9 @ryan10 years ago

  • Owner changed from anonymous to michel v
  • Status changed from new to assigned

comment:10 @paulcook10 years ago

This is almost certainly the same bug as 927; I've posted a fix there that worked for me. The problem is that the global variable $cache_pages is being used twice, for different purposes -- rename one of the uses, and everything works.

comment:11 @ryan10 years ago

We need to use the same cache for both otherwise there is little point in having a page cache. I'm working on a patch to make the two play nicely together.

comment:13 @anonymousbugger10 years ago

That fixed the problems. Yay.

comment:14 @ryan10 years ago

  • fixed_in_version set to 1.5.1
  • Resolution changed from 10 to 20
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.