Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#9373 closed defect (bug) (invalid)

default permalinks (post count issue)

Reported by: norwat Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: Permalinks Keywords: post ID, permalinks, url, plugins,
Focuses: Cc:


I have a problem with the interaction of WordPress and some of my plug-ins (SimpleTags, WP-o-Matic, and Feedpress). It was not a problem before 2.7, and it may affect WordPress independent of my plugins too.

In short, I have permalinks set to default setting (?p=123). If I make any adjustments to the post, such as manage tags with SimpleTags, it ticks off a post ID slot (but it does not generate a new post). For example: if last post is ?p=123, and I modify tags on five existing posts, the next new post will have the id ?p=129.

I do not like long post URLs, and prefer the default permalink setting, but this behavior is annoying and a bother. In short, it very quickly ups the post count without generating any new posts. I have 320 or so posts, but my current post count is 1034. I believe the issue started with WordPress 2.7, and so I am identifying it as a WordPress bug (and not a plug-in bug).

Is it possible to fix this behavior in future updates so that the post count function works exclusively to enumerate new post IDs?

Change History (2)

comment:1 @filosofo7 years ago

Those extra ids are probably being used by revisions. You can turn them off by putting the following in wp-config.php:

define('WP_POST_REVISIONS', false);

comment:2 @mrmist7 years ago

  • Milestone Unassigned deleted
  • Resolution set to invalid
  • Status changed from new to closed

#7373 was the same and was closed by a core dev. It's the intended behaviour and you can't rely on these being consecutive any more.

Note: See TracTickets for help on using tickets.