Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#9399 closed defect (bug) (fixed)

“Post Tags” string (on admin menu and in Post Tags metabox) not translatable

Reported by: demetris Owned by: nbachiyski
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: I18N Keywords: has-patch
Focuses: Cc:


I’m seeing this on r10845 with the latest wordpress.pot.


Attachments (1)

create-taxonomies-on-init.diff (1.5 KB) - added by nbachiyski 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 @hakre7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

If it is a new string, then the translation teams need to get some time to translate it first. As long as there is no translation available, the default string will be displayed.

Which language are you using?

comment:2 @demetris7 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version set to 2.8

hakre, the ticket says that the string is not translat*able*, not that it is not tranlat*ed*.

To be more exact, and to provide some information I should have provided when I opened the ticket, there *is* a “Post Tags” string in the trunk wordpress.pot, I translated it, but I keep seeing the original string.

comment:3 @nbachiyski6 years ago

  • Keywords has-patch added

The problem is that the default taxonomies are created before the translations are loaded. Here is a patch, which moves the creation on init.

comment:4 @ryan6 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [10965]) Create default taxonomies upon init. Props nbachiyski. fixes #9399

Note: See TracTickets for help on using tickets.