WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 12 years ago

#9413 closed task (blessed) (fixed)

Update to SWFUpload 2.2.0.1 final

Reported by: azaozz Owned by: azaozz
Milestone: 2.8 Priority: high
Severity: normal Version: 2.8
Component: Upload Keywords: has-patch dev-feedback
Focuses: Cc:

Description

SWFUpload version 2.2.0 has just been released and includes several fixes and improvements.

Attachments (2)

9413.patch (82.7 KB) - added by hakre 12 years ago.
SWFUpload v2.2.0.1 update
9413.swfupload-2.2.0.1-final.zip (38.3 KB) - added by hakre 12 years ago.
All Files, UTF-8 conversion done.

Download all attachments as: .zip

Change History (25)

#1 @hakre
12 years ago

Would be nice to know why this is interesting for WordPress. I mean, does it not work or does it work? Will the new version fix any WordPress Bugs and when yes, which ones?

More Infomration would be nice to have.

#2 @ryan
12 years ago

http://swfupload.org/forum/news/1370

We're currently running a beta version of SWFUpload.

#3 @simek
12 years ago

SWFUpload 2.2.0.1 Released : )

#4 @hakre
12 years ago

Ryan, is the betw version part of SVN?

#5 @Nicholas91
12 years ago

  • Cc dragos.nicholas@… added
  • Keywords dev-feedback added

#6 @Nicholas91
12 years ago

  • Priority changed from normal to high

#7 @ryan
12 years ago

  • Type changed from enhancement to task (blessed)

#8 @Denis-de-Bernardy
12 years ago

  • Keywords needs-patch added

#9 follow-up: @hakre
12 years ago

I can not find the correct version number which is used in 2.8 bleeding. From what I've seen so far (plugin is in /wp-includes/js/swfupload) it is the 1.x branch. But this is just guessed. Can someone provide more infos? What is the current version number used?

#10 in reply to: ↑ 9 @Simek
12 years ago

Replying to hakre:

I can not find the correct version number which is used in 2.8 bleeding. From what I've seen so far (plugin is in /wp-includes/js/swfupload) it is the 1.x branch. But this is just guessed. Can someone provide more infos? What is the current version number used?

WordPress is currently using SWFUpload 2.2.0 Beta 2 - "swfupload.js" line 52.

@hakre
12 years ago

SWFUpload v2.2.0.1 update

#12 @hakre
12 years ago

SWFUpload v2.2.0.1

Dropped Flash Player 8 support
Dropped the v1.0.2 plugin
Dropped the Graceful Degradation plugin

source: http://swfupload.googlecode.com/files/SWFUpload%20v2.2.0.1%20Core.zip
see also: http://code.google.com/p/swfupload/

#13 @hakre
12 years ago

  • Keywords has-patch added; needs-patch removed

First test did work properly with Chrome 1 on Win XP SP 3.

#14 @hakre
12 years ago

Not that easy to patch. Files are need to remove, binary files not part of .patch (?!). See attached .zip for all files.

@hakre
12 years ago

All Files, UTF-8 conversion done.

#15 @ryan
12 years ago

  • Owner set to azaozz

swfupload-all.js needs to be updated.

#16 @hakre
12 years ago

i think that one isn't needed any longer. at least I tested w/o that file. maybe the cache fooled me?

#17 @ryan
12 years ago

swfupload-all is something we created. I think it's just a concatenation of the js. azaozz knows the details.

#18 @hakre
12 years ago

  • Summary changed from Update to SWFUpload 2.2.0 final to Update to SWFUpload 2.2.0.1 final

#19 @Denis-de-Bernardy
12 years ago

See also #9417, which is hakre suggests is a bug related to the current files not being utf8 encoded.

#20 @Denis-de-Bernardy
12 years ago

might be related: #8806, #6509

#21 @azaozz
12 years ago

(In [11372]) Update SWFUpload to 2.2.0.1, see #9413

#22 @ryan
12 years ago

Close?

#23 @ryan
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.