WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9433 closed defect (bug) (fixed)

Patch for #9199 adds extra backslashes to pending-review previews

Reported by: ramenboy Owned by:
Milestone: 2.8 Priority: high
Severity: major Version: 2.7
Component: Administration Keywords:
Focuses: Cc:

Description

Changesets [10620] and [10621] for #9199 causes broken previews for posts with non-draft status.

Steps to reproduce:

  1. Posts -> Add New
  2. Enter a title with quotes and apostrophes
  3. Enter content with quotes and apostrophes
  4. In the Publish box next to "Status: Draft", click "Edit"
  5. Change status to "Pending Review", click "OK"
  6. Click "Save as Pending"
  7. Click "Preview"
  8. Quotes and apostrophes in title and content will have backslashes before them

In addition to mangling the text, this is causing broken images in previews.

Rolling back the change fixes the problem, though it probably reintroduces the original issue #9199.

Change History (17)

#1 @ramenboy
11 years ago

  • Version set to 2.7

Observed in 2.7 and trunk.

#2 @Denis-de-Bernardy
11 years ago

Cross posting, possibly related: #9372

#3 @Denis-de-Bernardy
11 years ago

  • Component changed from General to Administration
  • Milestone changed from Unassigned to 2.8

#4 @janeforshort
11 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to feature freeze. Reconsider with next release.

#5 @Denis-de-Bernardy
11 years ago

  • Milestone changed from Future Release to 2.8

Confirmed here.

@Jane: This is too major to wait.

#6 @Denis-de-Bernardy
11 years ago

  • Priority changed from normal to high
  • Severity changed from normal to major

#7 @Denis-de-Bernardy
11 years ago

  • Milestone 2.8 deleted
  • Resolution set to fixed
  • Status changed from new to closed

seems fixed in trunk. please re-open with feedback if you experience this again.

#8 @ramenboy
11 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

I just updated to the latest trunk, and I am still able to reproduce this. There have been no changes to post.php since [10620], so I don't see why it would be fixed.

#9 @Denis-de-Bernardy
11 years ago

weird. I tried it earlier today, and apart from the broken preview link that is highlighted in a separate ticket it seemed to work fine...

#10 @hakre
11 years ago

Unable to reproduce. I get a big fat JS Error on the Add Mew Page with 2.8 Bleeding. Sorry.

#11 @hakre
11 years ago

Fixed my error and tried to reproduce. I was able to reproduce (latest trunk). The slashes article is dispolayed. There is a post _with_ slashes in the database. Looks like somewhere this got slashed like hell before saved in the database.

Save as Pending a second time and then previewing does not have such errors. the old database entry is fixed then (that one that was with slashes inside the db), the new is okay then.

mysterious mircale.

#12 @hakre
11 years ago

  • Keywords confirmed needs-patch developer-feedback added

#13 @DD32
11 years ago

  • Keywords dev-feedback added; developer-feedback removed
  • Milestone set to 2.8

Resetting to 2.8 since its a bug thats been confirmed.

#14 @ryan
11 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [11117]) Don't double escape autosaves. fixes #9433

#15 @hakre
11 years ago

Tested: OK.

#16 @hakre
11 years ago

  • Keywords confirmed needs-patch removed

#17 @hakre
11 years ago

  • Keywords dev-feedback removed
Note: See TracTickets for help on using tickets.