WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9578 closed enhancement (worksforme)

Press This inserts hotlink src to image original URLs instead of crossloaded URL

Reported by: darjeelingwanderer Owned by: noel
Milestone: Priority: low
Severity: minor Version: 2.8
Component: Press This Keywords: needs-patch 2nd-opinion
Focuses: Cc:

Description

When using Press This to insert an image, the code will crossload a copy of the image to your local WordPress blog but will use the image's original URL as the src attribute of the img tag. Shouldn't this use the local URL of the crossloaded image and instead put the original URL as the href in a hotlink around the image?

Change History (5)

comment:1 Denis-de-Bernardy5 years ago

  • Keywords needs-patch 2nd-opinion added; pressthis images hotlinks removed
  • Milestone changed from Unassigned to 2.8

comment:2 hakre5 years ago

  • Priority changed from normal to low
  • Severity changed from normal to minor

Reproduceable. Does insert the image URL and SRC. To workaround, press the ADD: Images Button and insert Image manually.

comment:3 hakre5 years ago

  • Milestone changed from 2.8 to Future Release
  • Type changed from defect (bug) to enhancement
  • Version changed from 2.7.1 to 2.8

I've taken a look into it. The image is not uploaded when you press the bookmarklet. Instead it is uploaded when you press the image tab and actually insert the image.

Tested on the following URI:
http://s.wordpress.org/screenshots/2.7/ss1.png

Since this works as entended, this is not a Bug.

comment:4 in reply to: ↑ description hakre5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to darjeelingwanderer:

When using Press This to insert an image, the code will crossload a copy of the image to your local WordPress blog but will use the image's original URL as the src attribute of the img tag.

Once saved, it will replace the IMAGE-SRC to with the one of the local copy.

Shouldn't this use the local URL of the crossloaded image and instead put the original URL as the href in a hotlink around the image?

It does already use the local URL after save. And the original URL is placed as A-HREF around the image.

Whew. No I fully understand what you meant. The good thing is: nothing to fix with 2.8.

comment:5 Denis-de-Bernardy5 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.