WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9590 closed enhancement (worksforme)

Shift+Alt+A shortcut does not work in visual editor in webkit browsers

Reported by: yoavf Owned by: azaozz
Milestone: Priority: low
Severity: minor Version: 2.8
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

probably since [10994]. Other kb shortcuts seems to work fine (ie shift+alt+t)

Change History (6)

comment:1 @Denis-de-Bernardy6 years ago

  • Keywords needs-patch added

comment:2 @hakre6 years ago

  • Resolution set to worksforme
  • Status changed from new to closed
  • Type changed from defect (bug) to enhancement

checked against current trunk. shift+alt+a does work in visual editor.

i get the Insert/edit link html-form-dialog when the richedit element has the focus.

i get a javascript alert box to type in an url if the richedit element does not have the focus.

tested with google chrome.

so looks like there could be a little improvement for the richedit or a more restrictive handling for the html edit.

i think the latter is better. but this is worksforme for the component TinyMCE.

comment:3 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback added; needs-patch removed
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Works fine in safari. But not in Camino. No idea about FF.

I cannot remember if it has ever worked in Camino, though.

comment:4 @hakre6 years ago

safari is webkit. camino and ff are gecko. this ticket is about webkit. should this ticket be extended?

ff: shift+alt+a works as intended.

comment:5 @Denis-de-Bernardy6 years ago

  • Milestone 2.8 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Let's close, then. It sounds like a Camino or TinyMCE bug more than anything else.

@yoavf: Please re-open with more details if it's still occurring.

comment:6 @azaozz6 years ago

We can change the shortcut keys even make them browser/OS specific. If someone wants to experiment with this, they are defined in the wordpress plugin for TinyMCE, https://core.trac.wordpress.org/browser/trunk/wp-includes/js/tinymce/plugins/wordpress/editor_plugin.dev.js#L167

Note: See TracTickets for help on using tickets.