WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#9615 closed defect (bug) (fixed)

“Incompatible Archive” in FTP upgrading after r11025 (pclzip)

Reported by: demetris Owned by:
Milestone: 2.8 Priority: high
Severity: normal Version: 2.8
Component: Upgrade/Install Keywords: has-patch tested commit
Focuses: Cc:

Description

r11024 works OK.

In r11025 I get:

Downloading update from...

Unpacking the update.

Incompatible Archive.

Tested on two different servers/setups.

Please let me know if you need more info.

Attachments (1)

t9615-pclzip-v2.8-with-c7314.diff (39.0 KB) - added by demetris 6 years ago.
Updates class-pclzip.php to pclzip v2.8 and reapplies patch 7314

Download all attachments as: .zip

Change History (21)

comment:1 @Denis-de-Bernardy6 years ago

wherefrom is this? wordpress.org, or your own server?

I ask, because I had the same issue on my end at one point, and zipping from the server (rather than from my desktop) fixed it.

comment:2 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback added; pclzip removed

comment:3 @ryan6 years ago

Could be the pclzip upgrade, or it could be network problems. I used to see this with incomplete downloads due to timeout that somehow didn't trigger a download error.

comment:4 @demetris6 years ago

I switched class-pclzip.php a few times between r11024 and r11025 and the problem (Incompatible Archive) only occurs in r11025, consistently.

@Denis-de-Bernardy: I’m upgrading automatically, from wp.org. I click “upgrade automatically” on a plugin, then, on the Upgrade Plugin page, I click Proceed, and I get the message.

comment:6 @ryan6 years ago

  • Priority changed from normal to high

comment:7 @ryan6 years ago

(In [11038]) Use dist pczlip. see #9615 #9464

comment:8 @ryan6 years ago

I updated pclzip to the distribution version, without any of our whitespace changes, just in case something went wrong there. If that doesn't help, we can try 2.6 and then revert back to 2.5 if need be.

comment:9 follow-up: @demetris6 years ago

Problem persists with distribution version of pclzip 2.7. (As before, reverting class-pclzip.php to r11024 solves the problem.)

Maybe we should report this upstream?

comment:10 in reply to: ↑ 9 @Denis-de-Bernardy6 years ago

Replying to demetris:

Maybe we should report this upstream?

please do, if you know where.

comment:11 @demetris6 years ago

A new version of pclzip came out today: 2.8. I tried it and it has the same problem.

@Denis:

The pclzip readme gives this address for bug reports:

http://sourceforge.net/tracker/?group_id=40254&atid=427564

But I think I’ll leave the bug-reporting to someone who understands how this thing works. :-)

comment:12 @DD326 years ago

This is working for me on a Windows XP machine.. About to test with a Linux machine..

comment:13 @DD326 years ago

Confirmed on a linux x64 server.

comment:14 @DD326 years ago

PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

is the error. Reminds me of the x64 dragons in #6236 Which i thought had been fixed in PclZip..

comment:15 @DD326 years ago

Infact.. Its the exact same damn issue, The x64 patch which was submitted upstream is not in the latest versions. re-apply [7314] and everything works.

comment:16 @demetris6 years ago

Thanks, DD32!

I applied [7314] to pclzip 2.8 (released today, 2009-04-22) and it works again.

I’m attaching the patch.

@demetris6 years ago

Updates class-pclzip.php to pclzip v2.8 and reapplies patch 7314

comment:17 @Denis-de-Bernardy6 years ago

seems the sourceforge bug tracker has no trace of the above-mentioned issue though.

comment:18 @Denis-de-Bernardy6 years ago

  • Keywords has-patch tested commit added; reporter-feedback removed

comment:19 @automattor6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11056]) Update pclzip to 2.8 and apply x64 patch. Props demetris. fixes #9615

comment:20 @DD326 years ago

seems the sourceforge bug tracker has no trace of the above-mentioned issue though.

Thats because that tracker is virtually dead. I think 2 of us contacted the author via Email (And got positive responses) tho..

Note: See TracTickets for help on using tickets.