WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#9623 closed defect (bug) (invalid)

SimplePie seems to cache http errors

Reported by: Denis-de-Bernardy Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.8
Component: Optimization Keywords:
Focuses: Cc:

Description

it might be that it was just a glitch on my end, but I'm pretty certain that the WP_Feed_Cache_Transient class ended up caching a transport error.

if caching is really needed here, might it make sense to make it cache it for an hour only? (or less)

Change History (6)

comment:1 @ryan6 years ago

  • Component changed from Optimization to Widgets
  • Owner anonymous deleted

comment:2 @janeforshort6 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to feature freeze. Reconsider with next release.

comment:3 @Denis-de-Bernardy6 years ago

  • Milestone changed from Future Release to 2.8
  • Severity changed from normal to major

bumping this back to 2.8, as it can have potentially devastating effects (if confirmed) for feeds that are unavailable. specifically, you'd end up with a remote call to a host on every page load until it would succeed. (potential test: use a local install, and shut down your internet connection before you add an arbitrary feed).

comment:4 @Denis-de-Bernardy6 years ago

  • Component changed from Widgets to Optimization
  • Owner set to anonymous
  • Summary changed from rss widget seems to cache http errors to SimplePie seems to cache http errors

comment:5 @Denis-de-Bernardy6 years ago

  • Milestone changed from 2.8 to Future Release
  • Severity changed from major to minor

comment:6 @Denis-de-Bernardy6 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

haven't seen issues lately, so either fixed or never was valid

Note: See TracTickets for help on using tickets.