Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#9630 closed defect (bug) (worksforme)

Comments RSS feed from a specific category with CAT ID... Broken in 2.7

Reported by: SimonJ Owned by:
Milestone: Priority: low
Severity: normal Version: 2.7
Component: Feeds Keywords: reporter-feedback
Focuses: Cc:


I described the problem here :


Long story short : trying to get the COMMENTS RSS feed from a category doesn't work since I upgraded to 2.7


This link leads to a "not found".

I didn't have answer on the forum where I asked people to test it in their installation, so I submit here to see if you can reproduce the problem.

For instance, while asking google god about this problem, I found the Ryan Boren's Blog whom explain the "feed everywhere" feature for wordpress 2.2 wich include the possibility to get the comments feed from a category:


But, If I follow the link on his page, it leads to a "page not found"... The same problem that I have... :


If it's not a bug, just tell me where I'm wrong and close this ticket.



Change History (15)

#1 @Denis-de-Bernardy
7 years ago

  • Keywords needs-patch added
  • Milestone changed from Unassigned to 2.8

#2 @hakre
7 years ago

  • Keywords reporter-feedback added; needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

I get a 404 / File not found if the Category (XX in your Example) does not exists.

I get a 200 if it exists.

For Example, the URL in my Testsystem for getting the RSS2 Feed of Categroy "Cat 1" is:

This does work for me. Have you checked that the category you request acuallty exists? Don't feel offended, until you provide more feedback I close this ticket as "works for me". You can re-open it any time if you like.

#3 @Denis-de-Bernardy
7 years ago

  • Milestone 2.8 deleted

#4 @SimonJ
7 years ago

  • Priority changed from normal to low
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Summary changed from Comments RSS feed from a specific category... Broken in 2.7 to Comments RSS feed from a specific category with CAT ID... Broken in 2.7

Of course I checked with a category that actually exist. On many installation.

Maybe I wasn't clear enough... The XX should work with the cat ID ... At least, it did before my upgrade to 2.7...

Here is a live example :

This, like you found (thanks by the way) works :


But this doesn't :


"10001" is the ID of "chroniques"...

And this also works :


And this also doesn't work :


I changed the title to include the ID issue, changed priority to low and reopened.

I Don't want to sound too fancy, but something seems really broken when you try to use the Cat ID... Will have pretty long url if my category name is something like :"the-pros-and-cons-about-heidegger-metaphyisic"...



#5 @hakre
7 years ago

Yeah, I tested that with slugs and with the numerical ID value. I tested that against 2.8 trunk and it works. maybe you need to rebuild permalinks. in my test, the browser was redirected (category is "cat-1" with id 3):

the request

gets redirected to

are you experiencing this problem with wp 2.7 or wp 2.7.1?

#6 @SimonJ
7 years ago

Have this problem with Wordpress 2.7, as stated in the ticket.

I'll try the permalink rebuild right now.


#7 @hakre
7 years ago

is updating to wp 2.7.1 not an option?

additionally i'm encountering now problems as well. not found messages and listing of posts in a category feed that are not part of the category.

#8 @hakre
7 years ago

all looks ok for me after rebuilding permalinks myself again but not the link withcomments. - works - does not work

#9 @SimonJ
7 years ago

Hum. Rebuilding the permalinks give a strange issue... With the cat ID The page is indeed found, but in firefox it displays no comments, although they are visible in the source...


I have the same issue on a dev install, with no permalinks at all. Page found, no output, but comments visible in the source... :


I'll see if upgrade solve this issue.


#10 @Denis-de-Bernardy
7 years ago

  • Milestone set to 2.8

#11 @Denis-de-Bernardy
7 years ago

  • Milestone 2.8 deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

definitely working in trunk... please re-open with a test case to reproduce, if it's not on your end.

#12 @hakre
7 years ago

just checked today against trunk again. works here as well now, even the case that did not 2 weeks ago.

#13 @tntc1978
6 years ago

  • Cc tntc1978 added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I think this bug has snug into core somehow again. In the examples below, I'm using a category called example with ID 23.

redirects to:
and shows all comments on the site.

redirects to:
and gives me a 404 message

#14 @greenshady
6 years ago

I've tested every configuration mentioned in this ticket and either get the full comments feed or a 404 while running version 2.9.2.

#15 @nacin
5 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.