WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#9653 closed defect (bug) (invalid)

Notice Error in category-template

Reported by: REGA1976 Owned by: filosofo
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Taxonomy Keywords: needs-patch reporter-feedback
Focuses: Cc:

Description

Notice: Object of class stdClass could not be converted to int in /var/www/wpcms/wp-includes/category-template.php on line 31

The Notice Error is in v2.8 and also in v2.7.x (there in line 65)

find the code in line 31

$category->parent == $category_id recursive recursion

and fix it to the following code

if ( isset($category->parent) == $category_id ) recursive recursion

Attachments (1)

category-template.php (30.3 KB) - added by REGA1976 5 years ago.

Download all attachments as: .zip

Change History (7)

REGA19765 years ago

comment:1 REGA19765 years ago

  • Component changed from General to Warnings/Notices
  • Owner anonymous deleted
  • Priority changed from low to normal
  • Type changed from defect (bug) to enhancement

comment:2 janeforshort5 years ago

  • Keywords has-patch needs-testing added

comment:3 Denis-de-Bernardy5 years ago

  • Keywords needs-patch reporter-feedback added; Notice Error has-patch needs-testing removed
  • Milestone changed from 2.8 to Future Release

patch (and suggested fix) is not valid.

can you outline a means to reproduce this? the parent is a string ref when I test it.

comment:4 Denis-de-Bernardy5 years ago

  • Component changed from Warnings/Notices to Taxonomy
  • Owner set to filosofo

comment:5 Denis-de-Bernardy5 years ago

  • Milestone changed from Future Release to 2.9
  • Type changed from enhancement to defect (bug)

comment:6 westi5 years ago

  • Milestone 2.9 deleted
  • Resolution set to invalid
  • Status changed from new to closed

Cant reproduce this at all or identify any issue by inspection.

Closing as Invalid.

Note: See TracTickets for help on using tickets.