WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 11 years ago

Last modified 6 years ago

#9737 closed enhancement (worksforme)

Use a "thumbnail" rather than HTML width/height for "fullsize" images

Reported by: Viper007Bond Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

Related: #7119

If you upload an image off your camera (a few megapixels, aka huge) and then insert the "Fullsize" image into your post, WordPress will indeed insert an image tag for the original image, but with HTML width/height's based on the theme's GLOBAL width value to ensure it's not wider than the theme.

Since those width/height values are hard coded into the HTML and won't change if you change themes, why not just make a "thumbnail" with that width/height when the image is uploaded? That way viewers don't have to download the huge image and have it be resized by their browser (which looks bad).

Change History (4)

#1 @Denis-de-Bernardy
12 years ago

  • Milestone changed from Unassigned to Future Release

#2 @Denis-de-Bernardy
11 years ago

  • Milestone changed from Future Release to 2.9

#3 @miqrogroove
11 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

"works for me", 2 reasons:

In testing Version 2.8.4, I could not reproduce the behavior of "HTML width/height's based on the theme's GLOBAL width value" using the Full size option. WordPress happily inserted width="1680" height="1050" from the Media Gallery tab.

Viper's idea would duplicate the "Large" size feature. The Large size option already creates a "thumbnail" based on the theme's width.

#4 @DrewAPicture
6 years ago

  • Milestone 2.9 deleted
Note: See TracTickets for help on using tickets.