WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9791 closed defect (bug) (fixed)

Use a more semantic class name for screen reader class

Reported by: filosofo Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: Accessibility Keywords: has-patch screen-reader-text
Focuses: Cc:

Description

To be semantic, CSS classes (and ids) should describe meaning or function, not style.

So attached patch exchanges "invisible" for "screen-reader-text".

Attachments (1)

screen_reader_text.9791.diff (47.6 KB) - added by filosofo 5 years ago.

Download all attachments as: .zip

Change History (5)

comment:2 markjaquith5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11312]) Use a semantic class name for text targeted to screen readers. props filosofo. fixes #9791

comment:3 nbachiyski5 years ago

Isn't it targeted for browsers with no/disabled JavaScript, not for text readers specifically? This class name is really long, given the number of times it is used.

comment:4 filosofo5 years ago

I wasn't pushing for that name in particular, just something semantic.

Note: See TracTickets for help on using tickets.