WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9810 closed defect (bug) (fixed)

Revert RSS mime to text/xml

Reported by: Denis-de-Bernardy Owned by:
Milestone: 2.8 Priority: high
Severity: major Version: 2.8
Component: Feeds Keywords: has-patch needs-testing
Focuses: Cc:

Description

Same issue as here:

http://comox.textdrive.com/pipermail/wp-testers/2009-May/011534.html

On a Mac, you can no longer browse a feed in a browser. Leaving aside that it's annoying when you try to debug a patch that was applied to feed-related files, I'm not entirely certain that things end up working as expected with an XSL stylesheet.

Is there any room to revert this change?

Attachments (2)

9810.diff (568 bytes) - added by Denis-de-Bernardy 5 years ago.
9810.patch (2.1 KB) - added by peaceablewhale 5 years ago.
New patch that does not affect feed autodiscovery

Download all attachments as: .zip

Change History (16)

comment:1 Denis-de-Bernardy5 years ago

  • Severity changed from normal to minor

comment:2 sivel5 years ago

Don't you mean revert to text/xml?

comment:3 Denis-de-Bernardy5 years ago

  • Summary changed from Revert RSS mime to text/html to Revert RSS mime to text/xml

indeed. :)

comment:4 sivel5 years ago

Have you confirmed that this is a problem in Safari or on a Mac? According to http://developer.apple.com/internet/safari/faq.html#anchor22 they use application/rss+xml as an example for telling Safari about RSS feeds.

I would test now but my Mac is temporarily out of commission.

comment:5 Denis-de-Bernardy5 years ago

  • Keywords has-patch added

Yeah. It ends up triggering downloads when you try to view the HTML in Camino. And in safari, it goes straight into RSS Menu.

The safari behavior hasn't changed one bit, but the Camino (and presumably FF, since it's the same engine) issue is very real. Just like the reporter, my ~/Download folder is cluttered with localhost-* files. :-)

patch fixes this.

Denis-de-Bernardy5 years ago

comment:6 Denis-de-Bernardy5 years ago

  • Keywords tested commit added

comment:7 follow-up: ryan5 years ago

I think we've gone through this before and had to stick with text/xml to accommodate old browsers. Modern Safari and Firefox have no problems with application types.

comment:8 peaceablewhale5 years ago

Using text/xml with the charset parameter should be fine. +1 to the patch, unless dropping support to older browsers is acceptable.

comment:9 in reply to: ↑ 7 Denis-de-Bernardy5 years ago

Replying to ryan:

I think we've gone through this before and had to stick with text/xml to accommodate old browsers. Modern Safari and Firefox have no problems with application types.

not on a mac :-(

or rather, neither has issue with the application/rss+xml mime, it's just that Safari will send it straight to Mail or RSS Menu, and Camino/FF will download it as it would any app...

comment:10 ryan5 years ago

Hmmm, on Mac both FF and Safari display the feed for me and offer to add it to a reader. In FF, once you pick a default reader I think it always sends there instead of displaying. This happens for me regardless of the type.

Regardless, sounds like we're good to revert.

comment:11 ryan5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [11334]) Use text/xml for rss feeds for best browser compat. Props Denis-de-Bernardy. fixes #9810

comment:12 peaceablewhale5 years ago

  • Priority changed from normal to high
  • Resolution fixed deleted
  • Severity changed from minor to major
  • Status changed from closed to reopened

Reopening this report as the current patch breaks feed autodiscovery. New patch will be attached shortly.

peaceablewhale5 years ago

New patch that does not affect feed autodiscovery

comment:13 peaceablewhale5 years ago

  • Keywords needs-testing added; tested commit 2nd-opinion removed

A new patch has been uploaded.

comment:14 ryan5 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [11358]) Fix feed autodiscovery. Props peaceablewhale. fixes #9810

Note: See TracTickets for help on using tickets.