WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 3 years ago

Last modified 3 years ago

#9850 closed defect (bug) (worksforme)

Picture Insert failes if General Settings Address is MixedCaseDomainName

Reported by: CarltonBale Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7.1
Component: Gallery Keywords:
Focuses: Cc:

Description

Pictures/media will not insert into posts if the "WordPress address (URL)" or "Blog address (URL)" are entered using Mixed Case (i.e. if the address contains capital letter) in the Settings -> General configuration page.

So if I set the WordPress Address and Blog Address to CarltonBale.com and try to insert a picture into a post, the insert picture overlay goes blank, it does not return to the post, and the "x" button in the upper right has to be clicked to close the insert blank insert image overlay.

But if I set the WordPress Address and Blog Address to carltonbale.com, image insert starts working properly.

The code that determines the path to the image file apparently can't handle site names containing capital letters. This bug has been reproduced on versions 2.6.x, 2.7.0, and 2.7.1

Change History (7)

comment:1 @Denis-de-Bernardy6 years ago

  • Keywords needs-patch added
  • Milestone changed from Unassigned to Future Release

comment:2 @carltonbale6 years ago

This bug also prevent access to the admin control panel from iPhone Safari browser. Changing the site name to all lower caps resolves the issue and allows access.

comment:3 @Denis-de-Bernardy6 years ago

  • Milestone changed from Future Release to 2.9

comment:4 @janeforshort6 years ago

  • Milestone changed from 2.9 to Future Release

Punting b/c no patch. Should add to "known issues" in Codex if still a problem.

comment:5 @johnbillion5 years ago

  • Keywords Insert Picture Media Failure removed

If this was fixed by simply strtolower()-ing the blog URL when it's saved, would this cause any problems with IDNs?

comment:6 @solarissmoke3 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Tried this in trunk, and it doesn't seem to be a problem any more.

comment:7 @SergeyBiryukov3 years ago

  • Milestone Future Release deleted

FWIW, I couldn't reproduce in 2.7.1 as well (with Firefox 10).

Note: See TracTickets for help on using tickets.