WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#9857 closed enhancement (duplicate)

Use of JSMin with .js file concating for wp_enqueue_scripts

Reported by: akshay_raje Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: JavaScript Keywords: needs-patch
Focuses: Cc:

Description

Improvements to the script loader: Along with use of JSMin, there should also be an option of concating all the minified js scripts outputed by wp_enqueue_scripts into one file. This will reduce the server requests drastically (incase of plugin intensive installations) and considerably speed-up the output.

Change History (6)

comment:1 akshay_raje5 years ago

  • Cc akshay_raje added

comment:2 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added

wishing I could vote more than once for this one. ;-)

comment:3 Denis-de-Bernardy5 years ago

  • Keywords 2nd-opinion removed
  • Milestone changed from Future Release to 2.9

comment:4 ryan4 years ago

  • Milestone changed from 2.9 to Future Release

comment:5 azaozz4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Seems duplicate of a part of #3372

comment:6 sirzooro4 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.