WordPress.org

Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 9 years ago

#9866 closed defect (bug) (duplicate)

When the Page slug is in cyrillic and permalink is ON - 404 page not found

Reported by: kalifi Owned by: ryan
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Permalinks Keywords:
Focuses: Cc:

Description

Hello

  1. On fresh install of the Wordpress 2.8 beta
  2. Enable permalink - /%category%/%postname%
  3. Create post with slug "тест" - then you can access it trough the link from the side bar and the URL contains "тест" at the end
  4. Create Page with slug "страница" - the link "Страница" appears in the sidebar, but when you click it - 404 page not found, and the url is http://blogaddress/страница[[BR]]


The same bug exists in 2.7.1. I'm using MAMP with php 5 the permalinks are behaving normal when using just latin characters, the database is utf8_general_ci.

Hope you can fix this !

Miro

Change History (2)

#1 @Denis-de-Bernardy
11 years ago

  • Milestone 2.8 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

see #9591

#2 @SergeyBiryukov
9 years ago

Actually it's a duplicate of #10249 rather than #9591.

Note: See TracTickets for help on using tickets.