WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#9871 closed enhancement (invalid)

Avoid those PHP errors to be logged

Reported by: arena Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Warnings/Notices Keywords: dev-feedback
Focuses: Cc:

Description (last modified by dd32)

It is very surprising to log errors detected by php when under admin.

Removing those errors would help WordPress to be

* faster (php not trying to log those errors)
* more reliable
* compliant for PHP future versions !

hereattached, log file produced for each admin screen !

Attachments (9)

Log__wp-admin.txt (1.7 KB) - added by arena 6 years ago.
arriving on admin logging page
Log__loggedin.txt (1.2 KB) - added by arena 6 years ago.
once logged in
Log__dashboard.txt (26.9 KB) - added by arena 6 years ago.
dashboard
Log__edit_posts.txt (3.7 KB) - added by arena 6 years ago.
edit posts list
Log__add_new_post.txt (4.9 KB) - added by arena 6 years ago.
add new post
Log__themes.txt (5.1 KB) - added by arena 6 years ago.
themes
Log__plugins.txt (5.0 KB) - added by arena 6 years ago.
plugins
Log__users.txt (3.2 KB) - added by arena 6 years ago.
users list
Log__profile.txt (3.4 KB) - added by arena 6 years ago.
profile

Download all attachments as: .zip

Change History (15)

@arena6 years ago

arriving on admin logging page

@arena6 years ago

once logged in

@arena6 years ago

dashboard

@arena6 years ago

edit posts list

@arena6 years ago

add new post

@arena6 years ago

themes

@arena6 years ago

plugins

@arena6 years ago

users list

@arena6 years ago

profile

comment:1 @Denis-de-Bernardy6 years ago

  • Component changed from Optimization to Warnings/Notices
  • Keywords needs-patch added
  • Milestone changed from Unassigned to Future Release
  • Owner Denis-de-Bernardy deleted
  • Type changed from defect (bug) to enhancement

instanceof is php5.

Logedit_posts.txt contains a few notices.

Logdashboard.txt contains a warning.

Can you confirm this is with 2.8? E_STRICT shouldn't be raised in trunk.

comment:2 @dd326 years ago

  • Description modified (diff)

Due to PHP4 support, Its impossible not to trigger E_STRICT level warnings.

comment:3 @peaceablewhale6 years ago

  • Keywords dev-feedback added; needs-patch removed

is_a is no longer deprecated in PHP 5.3.0: http://www.php.net/manual/en/function.is-a.php

Since most E_STRICT messages are caused by it, I think this report can be resolved as "won't fix" until support to PHP 4 can be dropped.

comment:4 @Denis-de-Bernardy6 years ago

Agreed, but there actually are a few notices and warnings, so I had kept it open:

http://core.trac.wordpress.org/ticket/9871#comment:1

comment:5 @peaceablewhale6 years ago

The E_WARNING is actually a timed out error.

I am not able to reproduce the E_NOTICE message anyway...

comment:6 @Denis-de-Bernardy6 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

let's close then.

Note: See TracTickets for help on using tickets.