WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#9895 closed defect (bug) (worksforme)

Update Link Button sends to invalid URL and does not update resource.

Reported by: chrisale Owned by:
Milestone: 2.9 Priority: low
Severity: minor Version: 2.7.1
Component: Administration Keywords:
Focuses: Cc:

Description (last modified by Denis-de-Bernardy)

See: http://core.trac.wordpress.org/ticket/9895#comment:4

Original report, for reference, is invalid.


Procedure:

1: Create Link in Wordpress

2: Edit Existing Link

3: Make any changes in the Edit Link area

4: Click Update link

5: You are sent to http://www.yourblog.net/wp-admin/link.php&saved=true - 404 Not Found.

This is an invalid URL? The AND sign is invalid... should be a "?" like:

http://www.yourblog.net/wp-admin/link.php?saved=true

The only way to edit a link right now is to remove the existing link and recreate it.

Change History (9)

comment:1 @Denis-de-Bernardy6 years ago

  • Component changed from General to Administration
  • Milestone changed from 2.7.2 to 2.8
  • Priority changed from normal to high

comment:2 @ryan6 years ago

I cannot reproduce this with either 2.7.1 or 2.8, nor do I see any place in the code where we add "saved" to a link.php url. Can you still reproduce this if all plugins are disabled?

comment:3 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback added

comment:4 @mrmist6 years ago

  • Priority changed from high to normal
  • Severity changed from major to normal

This original bug is looking like a worksforme (Tested adding and updating in 2.7.1 and trunk and couldn't reproduce) however, there is another bug - if you add a new link and then add another new link straight (and so on) away the URL expands thusly

link-add.php?added=true?added=true?added=true

Which is not great. Hardly "severe" though, this one, in any respect.

comment:5 @Denis-de-Bernardy6 years ago

  • Milestone changed from 2.8 to Future Release

punting...

comment:6 @Denis-de-Bernardy6 years ago

  • Description modified (diff)
  • Keywords needs-patch added; reporter-feedback removed
  • Priority changed from normal to low
  • Severity changed from normal to minor

comment:7 @Denis-de-Bernardy6 years ago

  • Description modified (diff)

comment:8 @Denis-de-Bernardy6 years ago

  • Milestone changed from Future Release to 2.9

comment:9 @MattyRob5 years ago

  • Keywords needs-patch removed
  • Resolution set to worksforme
  • Status changed from new to closed

Links are edited in my trunk [12045] but a file called link-manager.php. That said it seems that link.php is called if JavaScript is disable but the link is still updated without issues, even in this case.

I am unable to reproduce this issue and it seems that others have been unable to reproduce either. Closing now as worksforme.

Note: See TracTickets for help on using tickets.