WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#9896 closed defect (bug) (fixed)

IE8 Comment Reply

Reported by: mtdewvirus Owned by: azzozz
Milestone: 2.9 Priority: normal
Severity: normal Version: 2.8
Component: Comments Keywords: reporter-feedback
Focuses: Cc:

Description

When browsing the Comments screen in IE8, the Reply action link doesn't work. It jumps the browser down to the bottom of the screen, but a Comment Reply area never appears.

r11422

Change History (9)

comment:1 demetris5 years ago

  • Cc dkikizas@… added
  • Keywords reporter-feedback added

IE8 works OK for me.

Do you have any plugins that use JavaScript in the admin area and could cause this? Try without plugins to see if it still appears.

comment:2 demetris5 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Tested again in IE8 with current revision (r11452) and I saw no problem. Closing as worksforme.

comment:3 designsimply5 years ago

  • Cc designsimply added
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Tested with a clean trunk (r11748) and still seeing this problem happening in IE8. Works in tests for FF/Safari on Mac and FF/Chrome/IE7 on PC. Problem only happens in IE8. When "Reply" is clicked, it jumps to the bottom of the page. If the last "Reply" is clicked, it jumps to the top of the page. The comment box never appears. Replying to comments directly from posts works though.

comment:4 designsimply5 years ago

  • Owner set to azzozz
  • Status changed from reopened to assigned

comment:5 azaozz5 years ago

This seems to be theme specific. Re-tested with several themes including the default and couldn't reproduce it. The comment-replay JS depends on some DOM elements and HTML IDs being present on the page and can easily be replaced with modified version when themes need to change them.

comment:6 designsimply4 years ago

Just to clarify, the problem is happening on wp-admin/edit-comments.php

I just re-tested on r12136, and I don't see the comment reply box when I click on Reply in IE8:
http://screencast.com/t/AbHg5uXC3g

comment:7 demetris4 years ago

OK, now it happens for me too! :-)

Confirmed for r12136 with Win7 and IE8 on three different setups, each using a different theme: Sandbox, Thematic, and Carrington.

I also tested with the default theme and with all plugins deactivated. The issue occurs with all combinations.

comment:8 azaozz4 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [12139]) Fix IE8 reply to comments from admin fade in/out, decrease comment undo timeout, hide comment reply when moving to trash, fixes #9896

comment:9 azaozz4 years ago

  • Milestone changed from 2.8 to 2.9
Note: See TracTickets for help on using tickets.