WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#9905 closed defect (bug) (fixed)

Widgets not removed after deletion

Reported by: stevesien Owned by: azaozz
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.8
Component: Widgets Keywords: needs-patch reporter-feedback
Focuses: Cc:

Description

Widgets do not delete properly, they remain in the sidebar even after deleted.

Change History (4)

comment:1 mrmist5 years ago

  • Keywords needs-patch reporter-feedback added
  • Milestone changed from Unassigned to 2.8
  • Summary changed from 2.8 beta 1 to Widgets not removed after deletion
  • Version set to 2.8

Not seeing this in current trunk. Which browser are you seeing this in and what process are you using to delete the widgets?

The only comment I would make is a UI issue with the widgets page, because you can drag from left to right to add, but you can't drag from right to left to remove, only to "deactivate". It seems counter-intuitive to have to click the widget and click remove. (Sorting that would be an enhancement though.)

comment:2 Denis-de-Bernardy5 years ago

  • Component changed from General to Widgets
  • Owner set to azaozz

He's almost certainly referring to old-style multi-widgets or old-style single-widgets.

I've the same issue (and quite a few more) with old-style widgets. And am rewriting them all for WP 2.8 as a result. He should probably do the same.

comment:3 azaozz5 years ago

See if [11427] fixes this.

comment:4 Denis-de-Bernardy5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Confirming fixed. Thanks a lot Andrew!

Note: See TracTickets for help on using tickets.