WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#9946 closed defect (bug) (worksforme)

Publishing/saving a post with formatting/images redirects to home page

Reported by: conanh Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.7
Component: Administration Keywords: reporter-feedback needs-testing publish posting redirect
Focuses: Cc:

Description

On some servers (seems to be consistent across the same server), when a user creates a post with any formatting (e.g. bold, color, an image, etc.), publishing or saving as a draft does not save the post but instead redirects from the post.php page to the root page.

This is basically what it looks like: http://www.screencast.com/t/WRut2fpoGa

I have three installs on the same server, each going to a different subdomain. Two of the installs are brand new with no plugins. All have the same problem, so my assumption is that the issue is likely related to an Apache or PHP setting.

Also, my install worked fine several weeks ago, then suddenly didn't. This seems to support the above hypothesis.

The problem exists in 2.7+, including the 2.8 beta 2.

Change History (4)

comment:2 @Denis-de-Bernardy6 years ago

  • Keywords reporter-feedback needs-testing added
  • Milestone changed from Unassigned to Future Release

need... steps... to reproduce. :-(

comment:3 @Denis-de-Bernardy6 years ago

  • Component changed from General to Administration
  • Milestone changed from Future Release to 2.9

comment:4 @ryan6 years ago

  • Milestone 2.9 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing pending more information. Perhaps mod_security?

Note: See TracTickets for help on using tickets.