WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9966 closed defect (bug) (invalid)

New Drag/Drop Widget Interface does not work in Wordpress 2.8

Reported by: grassrootspa Owned by: azaozz
Milestone: Priority: normal
Severity: normal Version: 2.8
Component: Widgets Keywords: reporter-feedback
Focuses: Cc:

Description

Hi guys, I've been running, editing and updating Wordpress for years, and have never had major problems with the various widget variations ...until now.

After installing Wordpress 2.8 beta 1 and beta 2 I have found it impossible to work with sidebar widgets (the new interface does not seem to work).

Under the new Wordpress 2.8 widget interface I simply cannot drag/drop wigets into my sidebars. While I can *sometimes* (after fiddling around with a widget) 'drag' widgets from under the 'Available Widgets' and 'Inactive Widgets' headings to the general sidebar area, once I drop them to a sidebar, nothing happens.

I'm also unable to 'open' the 'Inactive Widgets' via the triangle in the upper right-hand side. Trying to do so seems to make the screen (which was scrolled down to view their lower box section) jump back up to the top.

I've tested the widget interface in IE8, FF 3, Chrome, and Safari with no luck.

Apparently I'm not the only one having problems:

http://wordpress.org/support/topic/272517

My theme is Sandbox 1.5.1. I doubt this is a theme issue as the widget interface issue began when Wordpress 2.8 betas unveiled the new revamped widget interface.

Change History (11)

comment:1 follow-up: ryan5 years ago

Are there any JS errors?

Try reproducing with the default theme and all plugins disabled.

comment:2 Denis-de-Bernardy5 years ago

  • Milestone changed from Unassigned to 2.8

comment:3 in reply to: ↑ 1 grassrootspa5 years ago

Replying to ryan:

Are there any JS errors?

Try reproducing with the default theme and all plugins disabled.

No JS errors. It's like 'dragging' the widgets in the two left-hand boxes into empty air. When the error first started I tried the default theme and it didn't change anything.

comment:4 azaozz5 years ago

Sounds like general js troubleshooting problem: delete both wp-admin and wp-includes and upload fresh copies from freshly downloaded and unzipped install package (important), disable all plugins and switch to the default theme, clear the browser's cache/disable Gears if used and try again.

comment:5 Dene5 years ago

  • Cc Dene added

We received the same problem with beta 2. We did try under the default theme. We then reverted back to 2.7.1 and all seems to work fine.

comment:6 azaozz5 years ago

  • Keywords reporter-feedback added; widgets interface drag drop removed

Do widgets work in one of the WordPress 2.8 open demo sites (search Internet for "WordPress 2.8 demo")?

comment:7 ryan5 years ago

Or on wordpress.com for that matter. It is running 2.8, and I haven't seen any similar complaints about the widgets admin.

comment:8 follow-up: Larcha5 years ago

I have the same problem. Widgets cant be dragged to sidebars no matter what fiddling I try. Both beta 1 and 2 has this problem.
I am developing my project in a MS VPC environment on Windows XP Professional SP3, XAMPP 1.7.1 and and have tested borh with FF 3 and IE7.
In 2.7.1 I had no problems with dragging widgets.

comment:9 in reply to: ↑ 8 Larcha5 years ago

It seems to be a problem caused by the Thesis v1.4.2 theme in our case.
When testing widget drag with the both default themes the functionality works.

comment:10 Denis-de-Bernardy5 years ago

  • Milestone 2.8 deleted
  • Resolution set to invalid
  • Status changed from new to closed

comment:11 grassrootspa5 years ago

Hey guys, tried everything to figure out the cause of the WordPress 2.8 widget interface error and it turns out that the thing creating the problem was my IntenseDebate plugin!

When enabled the drop and drag interface is DOA.

Hope this helps (I know you don't handle plugin errors, but thought it was worth mentioning the cause)

Note: See TracTickets for help on using tickets.