Make WordPress Core

Changes between Initial Version and Version 1 of Ticket #9993, comment 25


Ignore:
Timestamp:
04/28/2016 09:12:08 PM (8 years ago)
Author:
stevenkword
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9993, comment 25

    initial v1  
    44This might be a case where the naming conventions don't quite make sense.  Both Atom and RSS feeds use the same `the_title_rss()` method in their respective templates.  The only difference being that the Atom template wraps the output in CDATA ,which would be unnecessary, but not problematic after this change.
    55
    6 Ideally, since both templates use XML, naming the method `the_title_feed()` would have been more appropriate.  While we do have the ability to add unit tests for Atom as of 4.5, I think the tests proposed in this ticket cover those test cases.  As a future part of adding test coverage for feeds, I would like to add a new `common.php` to `/tests/feed/` to help make things more obvious.
     6Ideally, since both templates use XML (the export component too), naming the method `the_title_xml()` would have been more appropriate.  While we do have the ability to add unit tests for Atom as of 4.5, I think the tests proposed in this ticket cover those test cases.  As a future part of adding test coverage for feeds, I would like to add a new `common.php` to `/tests/feed/` to help make things more obvious.