Fix balanceTags() docs and make the logic better readable
|Reported by:||TobiasBg||Owned by:||SergeyBiryukov|
|Severity:||normal||Keywords:||has-patch 3.6-early commit|
The inline documentation of balanceTags() mixes up "and" and "or" in the first line. The function will does not require both $force and get_option(...) to be true, but just one. Apparently, some of the inline docs was already worked on in #19576, but the first line was left as-is.
Also, the logic of the function is kind of hard to read with unnecessary boolean inversions.
The attached patch fixed the docs and makes the function better readable.
Change History (6)
- Component changed from General to Inline Docs
- Keywords 3.6-early added