Make the Name of the Widget optional
|Reported by:||hakre||Owned by:|
Per default a Widget should have the name of it's own class. That helps prototyping new Widgets because there is no need to over-ride the default Widgets Class constructor.
This established Documentation conform behavior as well because it is written:
* This class must be extended for each widget and WP_Widget::widget(), WP_Widget::update() * and WP_Widget::form() need to be over-ridden.
Without the patch the constructor function needs to be over-ridden as well. With the patch, the comment above is true then.
Change History (9)
- Priority changed from normal to low
- Severity changed from normal to minor
- Type changed from defect (bug) to enhancement
- Milestone 2.8 deleted
- Resolution set to wontfix
- Status changed from new to closed