WordPress.org

Make WordPress Core


Ignore:
Timestamp:
11/09/2019 12:57:27 PM (2 years ago)
Author:
SergeyBiryukov
Message:

Coding Standards: Consistently use do_action_deprecated() and apply_filters_deprecated() for deprecated hooks.

Props jrf.
See #48255.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-includes/class-wp-xmlrpc-server.php

    r46596 r46684  
    236236         * option was deprecated in 3.5.0. Use the 'xmlrpc_enabled' hook instead.
    237237         */
    238         $enabled = apply_filters( 'pre_option_enable_xmlrpc', false );
     238        $enabled = apply_filters_deprecated( 'pre_option_enable_xmlrpc', array( false ), '3.5.0', 'xmlrpc_enabled' );
    239239        if ( false === $enabled ) {
    240             $enabled = apply_filters( 'option_enable_xmlrpc', true );
     240            $enabled = apply_filters_deprecated( 'option_enable_xmlrpc', array( true ), '3.5.0', 'xmlrpc_enabled' );
    241241        }
    242242
Note: See TracChangeset for help on using the changeset viewer.