Make WordPress Core


Ignore:
Timestamp:
04/13/2022 03:56:23 PM (2 years ago)
Author:
desrosj
Message:

Script Loader: Specify the version of the clipboard library included when registering.

For external libraries, the current version included with WordPress should be specified when registering scripts.

Props elifvish.
Fixes #55565.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/src/wp-includes/script-loader.php

    r53165 r53173  
    733733    $scripts->add( 'editor', "/wp-admin/js/editor$suffix.js", array( 'utils', 'jquery' ), false, 1 );
    734734
    735     $scripts->add( 'clipboard', "/wp-includes/js/clipboard$suffix.js", array(), false, 1 );
     735    $scripts->add( 'clipboard', "/wp-includes/js/clipboard$suffix.js", array(), '2.0.10', 1 );
    736736
    737737    $scripts->add( 'wp-ajax-response', "/wp-includes/js/wp-ajax-response$suffix.js", array( 'jquery', 'wp-a11y' ), false, 1 );
Note: See TracChangeset for help on using the changeset viewer.